Home → Installation and Upgrade Manual → Installation Troubleshooting → Upgrade fails with "Tinker" / TinkerServiceProvider not found
5.9. Upgrade fails with "Tinker" / TinkerServiceProvider not found
Updated: 10 Sep 2026, 01:57 PM EDT
Applies to: Self-hosted HelpSpot 5 · upgrades to 5.8.0 and later
This error, and the related Command "update" is not defined, are both caused by stale bootstrap/cache files carried over from the previous version. The full cause, the Linux and Windows commands, and how to prevent it are in Upgrade Errors: "Command update is not defined" or Class Not Found.
Note the upgrade command is php hs update.
Related articles
This page was: Helpful |
Not Helpful